Planned Maintenancee
Incident Report for EduBrite Systems
Resolved
All systems are up now.
Posted Oct 13, 2019 - 04:37 CDT
Investigating
All systems are unavailable due to planned maintenance. We are expecting to be up in 4 hours.
Posted Oct 13, 2019 - 00:30 CDT
This incident affected: API, Accounts Site, Support Website, WWW, and Batch.